Vulnerability Note VU#987632

NewsDaemon does not adequately filter user input to $user_username

Original Release date: 05 May 2001 | Last revised: 25 Jun 2001


NewsDaemon prior to version 0.21b contains a vulnerability allowing remote attackers to gain administrative access to the web site.


NewsDaemon is a PHP-based tool used to allow readers to submit and comments on news items and stories over the web. It also allows for administration of the web site using HTTP. Versions of NewsDaemon prior to 0.21b allows readers of the web site to submit a malicious HTTP request allowing them to gain administrative access to the web site.


Remote intruders can gain administrative access to the web site.


Update to NewsDaemon version 0.21b or later. If you use PHP3, or cannot set register_globals offin PHP4, you must change NewsDaemon (including 0.21b) as described in the original description of this problem by Forrest J. Cavalier III.

Systems Affected (Learn More)

VendorStatusDate NotifiedDate Updated
DaemonNewsAffected-05 May 2001
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A N/A



Our thanks to Forrest J. Cavalier III who originally posted this information to BugTraq.

This document was written by Shawn V. Hernan

Other Information

  • CVE IDs: CAN-2001-0234
  • Date Public: 26 Jan 2001
  • Date First Published: 05 May 2001
  • Date Last Updated: 25 Jun 2001
  • Severity Metric: 3.19
  • Document Revision: 10


If you have feedback, comments, or additional information about this vulnerability, please send us email.