search menu icon-carat-right cmu-wordmark

CERT Coordination Center

Mozilla Firefox fails to properly perform security checks on "_search" target

Vulnerability Note VU#519317

Original Release Date: 2005-04-20 | Last Revised: 2005-12-22

Overview

A vulnerability in Mozilla Firefox may allow a remote attacker to install malicious code on or read protected information from a vulnerable system.

Description

The Firefox web browser features the ability to open a hyperlink in the "search" web panel. Firefox fails to perform adequate security checks on links opened in the web panel. According to the Mozilla advisory on this issue:

Sites can use the _search target to open links in the Firefox sidebar. Two missing security checks allow malicious scripts to first open a privileged page (such as about:config) and then inject script using a javascript: url. This could be used to install malicious code or steal data without user interaction.

Updated versions of the Firefox browser disallow javascript: and data: URIs from being opened in the search Web panel. They also perform an additional security check to prevent privileged pages, such as about:plugins, from being opened in the search Web panel.

Impact

A remote attacker may be able to install malicious code on or read protected information from a vulnerable system.

Solution

Upgrade

The Mozilla Software Foundation has published Mozilla Foundation Security Advisory 2005-39 in response to this issue. Users are encouraged to review this advisory and upgrade to the versions of the affected software it refers to.

Workarounds


Users who are unable to upgrade to a fixed version of the software are encouraged to disable Javascript in their browsers.

Vendor Information

519317
 
Affected   Unknown   Unaffected

Mozilla, Inc.

Updated:  December 22, 2005

Status

  Vulnerable

Vendor Statement

The Mozilla Software Foundation has published Mozilla Foundation Security Advisory 2005-39 in response to this issue.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Red Hat, Inc.

Updated:  December 22, 2005

Status

  Vulnerable

Vendor Statement

This issue, CAN-2005-1158, affected Firefox in Red Hat Enterprise Linux 4.
New firefox packages along with our advisory are available at the URLs
below and by using the Red Hat Network 'up2date' tool.  Red Hat
Enterprise Linux 2.1 and 3 were not affected by this issue.

http://rhn.redhat.com/errata/RHSA-2005-383.html

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.


CVSS Metrics

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A

References

Acknowledgements

Thanks to the Mozilla Foundation for reporting this vulnerability. The Mozilla Foundation, in turn, credits Kohei Yoshino with reporting this issue to them.

This document was written by Chad Dougherty and Will Dormann based on information provided by the Mozilla Foundation.

Other Information

CVE IDs: CVE-2005-1158
Severity Metric: 18.90
Date Public: 2005-04-15
Date First Published: 2005-04-20
Date Last Updated: 2005-12-22 19:47 UTC
Document Revision: 12

Sponsored by the Department of Homeland Security Office of Cybersecurity and Communications.