Vulnerability Note VU#673343

Parallels Plesk Panel phppath/php vulnerability

Original Release date: 07 Jun 2013 | Last revised: 07 Jun 2013


Parallels Plesk Panel versions 9.0 - 9.2.3 on Linux platforms are vulnerable to remote code execution.


Parallels Plesk Panel versions 9.0 - 9.2.3 on Linux platforms may be exploited by a combination of CVE-2012-1823 and the Plesk phppath script alias usage. There have been reports that this vulnerability is being exploited in the wild.


A remote unauthenticated attacker may be able to run arbitrary code under the context of the web server user.


Apply an Update

Parallels Plesk Panel 9.0 - 9.2.3 have been considered end-of-life software for over 3 years. Users should upgrade to at least 9.5.4 or later. Parallels will provide additional workaround mitigations in Knowledge base article 116241 soon.

Please consider the following workarounds if you are unable to upgrade.

Update PHP

Update PHP to protect against CVE-2012-1823.

Restrict Access

Do not allow untrusted networks to connect to the Plesk Panel.

Vendor Information (Learn More)

VendorStatusDate NotifiedDate Updated
Parallels Holdings LtdAffected06 Jun 201307 Jun 2013
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base 7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P
Temporal 6.5 E:H/RL:OF/RC:C
Environmental 4.9 CDP:ND/TD:M/CR:ND/IR:ND/AR:ND



Kingcope published an exploit for this vulnerability to the Full Disclosure mailing list.

This document was written by Jared Allar.

Other Information

  • CVE IDs: CVE-2012-1823
  • Date Public: 05 Jun 2013
  • Date First Published: 07 Jun 2013
  • Date Last Updated: 07 Jun 2013
  • Document Revision: 15


If you have feedback, comments, or additional information about this vulnerability, please send us email.