search menu icon-carat-right cmu-wordmark

CERT Coordination Center

libarchive contains a heap-based buffer overflow due to improper input validation

Vulnerability Note VU#862384

Original Release Date: 2016-05-02 | Last Revised: 2016-05-04

Overview

An attacker may be able to coerce a user into executing arbitrary code in the context of the current user by attempting to unzip a crafted zip file provided by the attacker.

Description

CWE-20: Improper Input Validation - CVE-2016-1541

A crafted zip file can provide an incorrect compressed size, which may allow an attacker to place arbitrary code on the heap and execute it in the context of the current user. The user must be coerced into unzipping the crafted zip file.

The researcher has confirmed that version 3.1.2 is impacted. Previous versions may also be affected.

Impact

An attacker may be able coerce a user into unzipping a file that executes arbitrary code in the context of the current user.

Solution

Apply an update

libarchive has released version 3.2.0 which addresses this problem. Affected users should update as soon as possible.

Vendor Information

862384
 
Affected   Unknown   Unaffected

libarchive

Notified:  February 22, 2016 Updated:  May 02, 2016

Statement Date:   April 30, 2016

Status

  Affected

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.


CVSS Metrics

Group Score Vector
Base 6.8 AV:N/AC:M/Au:N/C:P/I:P/A:P
Temporal 6.1 E:POC/RL:U/RC:C
Environmental 4.6 CDP:ND/TD:M/CR:ND/IR:ND/AR:ND

References

Credit

Thanks to Rock Stevens and Andrew Ruef for reporting this vulnerability.

This document was written by Garret Wassermann.

Other Information

CVE IDs: CVE-2016-1541
Date Public: 2016-05-01
Date First Published: 2016-05-02
Date Last Updated: 2016-05-04 18:58 UTC
Document Revision: 39

Sponsored by the Department of Homeland Security Office of Cybersecurity and Communications.