search menu icon-carat-right cmu-wordmark

CERT Coordination Center

Cisco IOS denial of service vulnerability

Vulnerability Note VU#936177

Original Release Date: 2008-03-26 | Last Revised: 2008-03-27

Overview

A vulnerability in the way Cisco IOS handles IPv6 packets could result in a remotely exploitable denial of service.

Description

The Cisco Internetwork Operating System (IOS) includes support for processing Internet Protocol version 6 (IPv6) packets.

Per Cisco Advisory cisco-sa-20080326-IPv4IPv6:
A device running Cisco IOS software that has Internet Protocol version 6 (IPv6) enabled may be subject to a denial of service (DoS) attack. For the device to be affected by this vulnerability the device also has to have certain Internet Protocol version 4 (IPv4) User Datagram Protocol (UDP) services enabled. To exploit this vulnerability an offending IPv6 packet must be targeted to the device. Packets that are routed throughout the router can not trigger this vulnerability. Successful exploitation will prevent the interface from receiving any additional traffic. The only exception is Resource Reservation Protocol (RSVP) service, which if exploited, will cause the device to crash. Only the interface on which the vulnerability was exploited will be affected.

Impact

A remote, unauthenticated attacker could cause a vulnerable system to crash or stop forwarding network traffic.

Solution

Upgrade

Cisco has made updates available to address this issue.


Disable IPv6

If it is not needed, disabling IPv6 access will mitigate this vulnerability. See the workarounds section of cisco-sa-20080326-IPv4IPv6 for more information.

Disable IPv4 UDP

If it is not needed, disabling UDP on IPv4 enabled interfaces will mitigate this vulnerability. See the workarounds section of cisco-sa-20080326-IPv4IPv6 for more information.

Vendor Information

936177
 
Affected   Unknown   Unaffected

Cisco Systems, Inc.

Updated:  March 26, 2008

Status

  Vulnerable

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Addendum

See http://www.cisco.com/warp/public/707/cisco-sa-20080326-IPv4IPv6.shtml for more information.

If you have feedback, comments, or additional information about this vulnerability, please send us email.


CVSS Metrics

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A

References

Credit

Thanks to Cisco for information that was used in this report.

This document was written by Ryan Giobbi.

Other Information

CVE IDs: CVE-2008-1153
Severity Metric: 10.55
Date Public: 2008-03-26
Date First Published: 2008-03-26
Date Last Updated: 2008-03-27 14:30 UTC
Document Revision: 13

Sponsored by the Department of Homeland Security Office of Cybersecurity and Communications.