Vulnerability Note VU#240329

Apache HTTPD server vulnerable to cross site scripting on error page when using wildcard DNS

Original Release date: 03 Oct 2002 | Last revised: 03 Oct 2002

Overview

Versions of the Apache HTTPD server with wildcard DNS enabled and UseCanonicalName disabled, are vulnerable to a cross-site scripting attack.

Description

Apache HTTPD servers versions 2.0.42 and prior, and 1.3.26 and prior, with wildcard DNS enabled and UseCanonicalName disabled, are vulnerable to a cross-site scripting attack via the error page. Only versions 2.0 to 2.0.33 have UseCanonicalName disabled by default. All other versions had UseCanonicalName enabled by default and are not vulnerable unless this option is disabled.

Impact

The victim will be presented with information which the compromised site did not wish their visitors to be subjected. This could be used to "sniff" sensitive data from within the web page, including passwords, credit card numbers, and any arbitrary information the user inputs.

Solution

This issue is resolved in Apache HTTPD Server versions 1.3.27 and 2.0.43.

Systems Affected (Learn More)

No information available. If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A N/A

References

Credit

Thanks to Matthew Murphy for reporting this vulnerability and the Apache Group for their technical assistance.

This document was written by Jason A Rafail.

Other Information

  • CVE IDs: CAN-2002-0840
  • Date Public: 02 Oct 2002
  • Date First Published: 03 Oct 2002
  • Date Last Updated: 03 Oct 2002
  • Severity Metric: 0.47
  • Document Revision: 6

Feedback

If you have feedback, comments, or additional information about this vulnerability, please send us email.