Vulnerability Note VU#255484

OpenSSL contains integer overflow handling ASN.1 tags (1)

Original Release date: 30 Sep 2003 | Last revised: 01 Oct 2003

Overview

A vulnerability in the way OpenSSL handles ASN.1 tags could allow a remote attacker to cause a denial of service.

Description

OpenSSL implements the Secure Sockets Layer (SSL) and Transport Layer Security (TLS) protocols and includes a general purpose cryptographic library. SSL and TLS are commonly used to provide authentication, encryption, integrity, and non-repudiation services to network applications such as HTTP, IMAP, POP3, LDAP, and others. Clients and servers exchange authentication information in X.509 certificates. While the SSL and TLS protocols are not directly based on ASN.1, they do rely on ASN.1 objects used in X.509 certificates and other cryptographic elements (e.g. PKCS#1 encoded RSA values).

OpenSSL contains an integer overflow vulnerability in the way ASN.1 tags are handled. A specially crafted ASN.1 tag could cause the OpenSSL library to perform an out-of-bounds memory read operation. This could result in a denial of service, crashing the process using the OpenSSL library.

From the OpenSSL advisory:


2. Unusual ASN.1 tag values can cause an out of bounds read under
certain circumstances, resulting in a denial of service vulnerability.

All versions of SSLeay and versions of OpenSSL prior to 0.9.7c or 0.9.6k are vulnerable, as are operating systems and applications that use vulnerable SSLeay or OpenSSL libraries. The OpenSSL advisory describes as vulnerable "Any application that makes use of OpenSSL's ASN1 library to parse untrusted data. This includes all SSL or TLS applications, those using S/MIME (PKCS#7) or certificate generation routines."

The U.K. National Infrastructure Security Co-ordination Centre (NISCC) is tracking this vulnerability (VU#255484) and VU#380864 as NISCC/006489/openssl/1.

Impact

By providing specially crafted ASN.1 encoded data to a vulnerable system, a remote attacker could cause a denial of service. One potential attack vector is a client certificate message containing specially crafted X.509 certificates.

Solution

Upgrade or Patch
Upgrade to OpenSSL 0.9.7c or 0.9.6k. Alternatively, upgrade or apply a patch as specified by your vendor. Further information is available in an advisory from OpenSSL. Note that it is necessary to recompile any applications that are statically linked to OpenSSL libraries.

Systems Affected (Learn More)

VendorStatusDate NotifiedDate Updated
MandrakeSoftAffected30 Sep 200330 Sep 2003
OpenSSLAffected-30 Sep 2003
Red Hat Inc.Affected30 Sep 200330 Sep 2003
ApacheUnknown30 Sep 200330 Sep 2003
Apache-SSLUnknown30 Sep 200330 Sep 2003
Apple Computer Inc.Unknown30 Sep 200330 Sep 2003
FreeBSDUnknown30 Sep 200330 Sep 2003
Guardian Digital Inc. Unknown30 Sep 200330 Sep 2003
Hewlett-Packard CompanyUnknown30 Sep 200330 Sep 2003
mod_sslUnknown30 Sep 200330 Sep 2003
OpenBSDUnknown30 Sep 200330 Sep 2003
StunnelUnknown30 Sep 200330 Sep 2003
SuSE Inc.Unknown30 Sep 200330 Sep 2003
TurboLinuxUnknown30 Sep 200330 Sep 2003
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A N/A

References

Credit

This vulnerability was discovered and researched by NISCC.

This document was written by Art Manion.

Other Information

  • CVE IDs: CAN-2003-0543
  • CERT Advisory: CA-2003-26
  • Date Public: 30 Sep 2003
  • Date First Published: 30 Sep 2003
  • Date Last Updated: 01 Oct 2003
  • Severity Metric: 11.25
  • Document Revision: 41

Feedback

If you have feedback, comments, or additional information about this vulnerability, please send us email.