Vulnerability Note VU#438616

Mortbay Jetty fails to properly handle cookies with quotes

Original Release date: 04 Dec 2007 | Last revised: 03 Dec 2007

Overview

Mortbay Jetty fails to properly handle cookie quotes, which may allow session hijacking.

Description

Mortbay Jetty is a web server that is written in Java. Jetty fails to properly handle cookies with certain quote sequences. This can cause the Jetty cookie parsing mechanism to improperly handle all of the cookies in the cookie string that follow the cookie with the quote sequence.

Impact

This vulnerability can increase the possibility of a session hijacking success. In the presense of a cross-site scripting vulnerability, it may allow a denial-of-service attack against a web site by preventing a client from being able to log in using cookies.

Solution

Apply an update

This issue is addressed in Mortbay Jetty 6.1.6. Details are available in the release notes.

Systems Affected (Learn More)

VendorStatusDate NotifiedDate Updated
Mort BayAffected25 Oct 200704 Dec 2007
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A N/A

References

Credit

Thanks to Tomasz Kuczynski for reporting this vulnerability.

This document was written by Will Dormann.

Other Information

  • CVE IDs: CVE-2007-5614
  • Date Public: 05 Nov 2007
  • Date First Published: 04 Dec 2007
  • Date Last Updated: 03 Dec 2007
  • Severity Metric: 2.78
  • Document Revision: 4

Feedback

If you have feedback, comments, or additional information about this vulnerability, please send us email.