Vulnerability Note VU#450646

Tiki Wiki CMS Groupware version 11.0 contains a cross-site scripting (XSS) vulnerability

Original Release date: 31 Oct 2013 | Last revised: 31 Oct 2013

Overview

Tiki Wiki CMS Groupware version 11.0 and possibly earlier versions contain a cross-site scripting (XSS) vulnerability (CWE-79).

Description

CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Tiki Wiki CMS Groupware version 11.0 and possibly earlier versions contain a cross-site scripting (XSS) vulnerability. An attacker can inject arbitrary script via the vulnerable query string parameter id of the ZeroClipboard.swf file.

For example:
http://www.example.com/tiki/files/ZeroClipboard.swf?id=\"))}catch(e{alert(document.domain);}//&width&height

Impact

A remote attacker may be able to execute arbitrary script in the context of the end-user's browser session.

Solution

Apply an Update

Please refer to the Tiki blog post for instructions on which patch is appropriate for your version of Tiki Wiki CMS Groupware.

Vendor Information (Learn More)

VendorStatusDate NotifiedDate Updated
Tiki Software Community AssociationAffected17 Oct 201331 Oct 2013
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base 6.4 AV:N/AC:L/Au:N/C:P/I:P/A:N
Temporal 5.8 E:POC/RL:ND/RC:C
Environmental 1.5 CDP:ND/TD:L/CR:ND/IR:ND/AR:ND

References

Credit

Thanks to Nikhil Kumar Srivastava from Techdefence Labs and Jinen Patel for reporting this vulnerability.

This document was written by Adam Rauf.

Other Information

  • CVE IDs: CVE-2013-6022
  • Date Public: 31 Oct 2013
  • Date First Published: 31 Oct 2013
  • Date Last Updated: 31 Oct 2013
  • Document Revision: 20

Feedback

If you have feedback, comments, or additional information about this vulnerability, please send us email.