Vulnerability Note VU#521612

Citrix NetScaler and Access Gateway Enterprise Edition unauthorized access to network resources vulnerability

Original Release date: 25 Apr 2013 | Last revised: 25 Apr 2013

Overview

Citrix NetScaler and Access Gateway Enterprise Edition contain a vulnerability which could result in unauthorized access to network resources.

Description

Citrix NetScaler and Access Gateway Enterprise Edition contain a vulnerability which could allow a remote attacker to gain unauthorized access to network resources.

For additional information please see Citrix Advisory.

Impact

A remote attacker could gain unauthorized access to internal network resources.

Solution

Upgrade

Citrix Advisory states:


    A new version of the NetScaler appliance firmware has been released to address this vulnerability. Citrix strongly recommends that affected customers upgrade their appliances to version 9.3.62.x or later as soon as possible. Customers using NetScaler Access Gateway Enterprise Edition in the Common Criteria evaluated configuration should upgrade to 9.3.53.6. These new firmware versions can be downloaded from the Citrix website at the following location: https://www.citrix.com/downloads/netscaler-adc/firmware.html

    Customers using NetScaler appliance firmware versions up to and including 10.0.74.4 in a double hop deployment should apply the following configuration change from the NSCLI:

    >add ns acl allowedHost ALLOW -srcIP <MIP/SNIP address of AGEE in the first DMZ> -destIP <ICA proxy VIP> -priority 10 #permit traffic only from the AGEE appliance in the first DMZ

    >enable ns acl allowedHost

    >add ns acl denyAll DENY -srcIP 0.0.0.0 - 255.255.255.255 -destIP <ICA proxy VIP> -priority 20 #block everything else

    >enable ns acl denyAll
    >apply ns acls

Vendor Information (Learn More)

Citrix Advisory states:

    This vulnerability affects the following NetScaler Access Gateway Enterprise Edition configurations:

    • All appliance firmware versions up to and including version 9.3.61.5 with the exception of Common Criteria build 9.3.53.6.

    • All version 10.0 appliance firmware up to and including version 10.0.74.4 when deployed in a double hop configuration only.
    Customers using an appliance with appliance firmware version 10.0 that is not deployed in a double hop configuration are not affected by this vulnerability.

VendorStatusDate NotifiedDate Updated
CitrixAffected15 Mar 201325 Apr 2013
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base 5.4 AV:N/AC:H/Au:N/C:C/I:N/A:N
Temporal 4.2 E:POC/RL:OF/RC:C
Environmental 4.5 CDP:LM/TD:M/CR:ND/IR:ND/AR:ND

References

Credit

Thanks to HyeongKwan Lee of SK Planet for reporting this vulnerability.

This document was written by Michael Orlando.

Other Information

  • CVE IDs: CVE-2013-2767
  • Date Public: 25 Apr 2013
  • Date First Published: 25 Apr 2013
  • Date Last Updated: 25 Apr 2013
  • Document Revision: 14

Feedback

If you have feedback, comments, or additional information about this vulnerability, please send us email.