Vulnerability Note VU#525132

Foscam IP camera authentication bypass vulnerability

Original Release date: 03 Mar 2014 | Last revised: 03 Mar 2014

Overview

The FI8910W Foscam IP camera running firmware version 11.37.2.54 fails to properly authenticate users.

Description

CWE-592: Authentication Bypass Issues - CVE-2014-1911

The FI8910W Foscam IP camera running firmware version 11.37.2.54 contains a vulnerability which allows an unauthenticated remote attacker to gain access to streaming video and image data.

Other models and firmwares may be affected.

Impact

An unauthenticated remote attacker may be able to gain privileged access to video and image data.

Solution

Apply an Update

Foscam advises users to upgrade to firmware 11.37.2.55. In addition, the following workaround is available:

Restrict Access
As a general good security practice, only allow connections from trusted hosts and networks. Appropriate firewall rules which block incoming connections from untrusted networks would likely prevent an external attacker from accessing the Foscam IP camera.

Vendor Information (Learn More)

VendorStatusDate NotifiedDate Updated
Shenzhen Foscam Intelligent TechnologyAffected22 Jan 201425 Feb 2014
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base 7.8 AV:N/AC:L/Au:N/C:C/I:N/A:N
Temporal 6.8 E:H/RL:OF/RC:C
Environmental 1.7 CDP:ND/TD:L/CR:ND/IR:ND/AR:ND

References

Credit

Thanks to KK "stiegl" for reporting this vulnerability.

This document was written by Todd Lewellen.

Other Information

  • CVE IDs: CVE-2014-1911
  • Date Public: 03 Mar 2014
  • Date First Published: 03 Mar 2014
  • Date Last Updated: 03 Mar 2014
  • Document Revision: 6

Feedback

If you have feedback, comments, or additional information about this vulnerability, please send us email.