Vulnerability Note VU#659209

GnuTLS Pad Length Denial of Service

Original Release date: 30 May 2008 | Last revised: 30 May 2008

Overview

A vulnerability exists in GnuTLS that may allow a remote attacker to cause a denial of service.

Description

GnuTLS contains a vulnerability in gnults-serv that may result in a denial of service when handling a sequence of specially crafted packets. According to CERT-FI Vulnerability Advisory on GnuTLS:

    We have found the flaw by doing complete TLS 1.0 handshake followed by a encrypted Client-Hello message to start abbreviated handshake. In this case the the Record Length field of the TLS Record containing the Client Hello contains erroneus value '8' triggering the bug. Note that this might not be the only way to reproduce the bug.

Note that this issue may affect GnuTLS versions prior to 2.2.5 and also affects version 2.3.0.

Impact

A remote, unauthorized attacker may be able to cause a denial of service.

Solution

Upgrade or Apply Patch
GnuTLS has issued an upgrade and a patch to address this issue. See GnuTLS Security Advisory SA-2008-01 for more information. GnuTLS is included in various Linux and UNIX distributions. Please consult the relevant documentation of your distribution to obtain the appropriate updates.

Systems Affected (Learn More)

VendorStatusDate NotifiedDate Updated
GnuTLSAffected-30 May 2008
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A N/A

References

Credit

This issue was reported in GnuTLS Security Advisory SA-2008-01. GnuTLS credits Ossi Herrala and Jukka Taimisto from the CROSS project at Codenomicon Ltd. for reporting this issue.

This document was written by Chris Taschner.

Other Information

  • CVE IDs: CVE-2008-1950
  • Date Public: 19 May 2008
  • Date First Published: 30 May 2008
  • Date Last Updated: 30 May 2008
  • Severity Metric: 16.54
  • Document Revision: 15

Feedback

If you have feedback, comments, or additional information about this vulnerability, please send us email.