Vulnerability Note VU#757612
Apache Portable Runtime contains heap buffer overflow in apr_psprintf()
The Apache HTTP server contains a denial-of-service vulnerability that allows remote attackers to conduct denial-of-service attacks against an affected server.
The Apache HTTP server contains a heap buffer overflow vulnerability in the apr_psprintf() function. The Apache Software Foundation has provided the following description of this vulnerability:
Apache 2.0 versions 2.0.37 through 2.0.45 can be caused to crash in certain circumstances. This can be triggered remotely through mod_dav and possibly other mechanisms. The crash was originally reported by David Endler <DEndler@iDefense.com> and was researched and fixed by Joe Orton <email@example.com>. Specific details and an analysis of the crash will be published Friday, May 30. No more specific information is disclosed at this time, but all Apache 2.0 users are encouraged to upgrade now.
For further information, please read the announcement located at
This vulnerability allows remote attackers to conduct denial-of-service attacks against an affected server.
The Apache Software Foundation recommends that users upgrade to version 2.0.46 to address this vulnerability. The latest version of Apache is available at:
Systems Affected (Learn More)
|Vendor||Status||Date Notified||Date Updated|
|Apache Software Foundation||Affected||28 May 2003||02 Jun 2003|
|Apple Computer Inc.||Affected||12 Jun 2003||24 Jun 2003|
|Conectiva||Affected||16 Jun 2003||23 Jun 2003|
|Hewlett-Packard Company||Affected||16 Jul 2003||18 Sep 2003|
|MandrakeSoft||Affected||02 Jun 2003||24 Jun 2003|
|Red Hat Inc.||Affected||28 May 2003||02 Jun 2003|
CVSS Metrics (Learn More)
The CERT/CC thanks David Endler for discovering this vulnerability.
This document was written by Jeffrey P. Lanza.
- CVE IDs: CAN-2003-0245
- Date Public: 28 May 2003
- Date First Published: 24 Jun 2003
- Date Last Updated: 18 Sep 2003
- Severity Metric: 18.00
- Document Revision: 15
If you have feedback, comments, or additional information about this vulnerability, please send us email.