OpenSSH Information for VU#997481

Cryptographic libraries and applications do not adequately defend against timing attacks

Status

Affected

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Vendor References

None

Addendum

<http://marc.theaimsgroup.com/?l=openbsd-announce&m=104912179501519&w=2>

    Changes since OpenSSH 3.5:
    ============================

    * RSA blinding is now used by ssh(1), sshd(8) and ssh-agent(1).
      in order to avoid potential timing attacks against the RSA keys.
      Older versions of OpenSSH have been using RSA blinding in
      ssh-keysign(1) only.

      Please note that there is no evidence that the SSH protocol is
      vulnerable to the OpenSSL/TLS timing attack described in
            http://crypto.stanford.edu/~dabo/papers/ssl-timing.pdf

    If you have feedback, comments, or additional information about this vulnerability, please send us email.