Debian Information for VU#929115

PHP fails to properly parse the headers of HTTP POST requests

Status

Affected

Vendor Statement

Debian GNU/Linux stable aka 3.0 is not vulnerable.

Debian GNU/Linux testing is not vulnerable.
Debian GNU/Linux unstable is vulnerable.

The problem effects PHP versions 4.2.0 and 4.2.1. Woody ships an older version of PHP (4.1.2), that doesn't contain the vulnerable function.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Vendor References

None

Addendum

The CERT/CC has no additional comments at this time.

If you have feedback, comments, or additional information about this vulnerability, please send us email.