Sun Microsystems Inc. Information for VU#958321

Samba contains a remotely exploitable stack buffer overflow

Status

Affected

Vendor Statement

Sun includes a version of Samba with Solaris 9 which is affected by this issue. Sun provides Samba on the Solaris Companion CD for Solaris 2.6, 7, and 8:

http://wwws.sun.com/software/solaris/freeware/index.html

as an unsupported package which installs to /opt/sfw and is vulnerable to this issue too. Sites using the freeware version of Samba from the Solaris Companion CD will have to upgrade to a later version from Samba.org. Sun has published Sun Alert 53580 for this issue describing the patches and workaround options here:

http://sunsolve.Sun.COM/pub-cgi/retrieve.pl?doc=fsalert/53580

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Vendor References

None

Addendum

Please see Sun Alert 53580.

If you have feedback, comments, or additional information about this vulnerability, please send us email.