Aladdin Systems Inc. Information for VU#383779

ZIP archives containing files with large filenames can cause buffer overflows

Status

Affected

Vendor Statement

Aladdin has determined that some versions of StuffIt may be vulnerable to the issue described in this notice.

The result of our findings by platform are:

Macintosh: StuffIt 7.0 including StuffIt Expander, StuffIt Standard Edition, and StuffIt Deluxe are NOT vulnerable. Pre 7.0 versions are potentially vulnerable. We recommend users concerned with earlier versions of StuffIt update to at least version 7.0 of StuffIt Expander which is available as a free component of the StuffIt Standard Edition (trialware) at: http://www.stuffit.com/expander/cert.html.

Windows: StuffIt for Windows 7.5 may be vulnerable when opening an archive to view, but is NOT vulnerable if the archive is expanded via drag & drop or the right-click contextual menu. When available we will make more information and or upgrade links available at: http://www.stuffit.com/expander/cert.html.

Linux/Solaris: StuffIt for Linux and Solaris has been tested and is NOT vulnerable.

Current versions of StuffIt Products are always available at http://www.stuffit.com

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Vendor References

None

Addendum

The CERT/CC has no additional comments at this time.

If you have feedback, comments, or additional information about this vulnerability, please send us email.