MandrakeSoft Information for VU#479268

Apache HTTPD contains denial of service vulnerability in basic authentication module

Status

Affected

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Vendor References

None

Addendum

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

________________________________________________________________________

Mandrake Linux Security Update Advisory
________________________________________________________________________

Package name:           apache2
Advisory ID:            MDKSA-2003:063-1
Date:                   June 2nd, 2003
Original Advisory Date: May 30th, 2003
Affected versions: 9.1
________________________________________________________________________

Problem Description:

Two vulnerabilities were discovered in the Apache web server that
affect all 2.x versions prior to 2.0.46.  The first, discovered by John
Hughes, is a build system problem that allows remote attackers to
prevent access to authenticated content when a threaded server is used.
This only affects versions of Apache compiled with threaded server
"httpd.worker", which is not the default for Mandrake Linux.


The second vulnerability, discovered by iDefense, allows remote
attackers to cause a DoS (Denial of Service) condition and may also
allow the execution of arbitrary code.


The provided packages include back-ported fixes to correct these
vulnerabilities and MandrakeSoft encourages all users to upgrade
immediately.


Update:

The previous update mistakenly listed apache-conf packages which were
never included, nor intended to be included, as part of the update.

________________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0189
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0245

________________________________________________________________________

Updated Packages:

Mandrake Linux 9.1:
d65381a88fcdd109974daf439d91484a  9.1/RPMS/apache2-2.0.45-4.3mdk.i586.rpm
b55e4f36efee37b6055dd4f6534701e8  9.1/RPMS/apache2-common-2.0.45-4.3mdk.i586.rpm
036667cc64f93c6227044eda60c010a1  9.1/RPMS/apache2-devel-2.0.45-4.3mdk.i586.rpm
d09e6bbcfabb98d1fbda5bef3f88d832  9.1/RPMS/apache2-manual-2.0.45-4.3mdk.i586.rpm
142a503a5cb05acbb351a6c381bb2a73  9.1/RPMS/apache2-mod_dav-2.0.45-4.3mdk.i586.rpm
84f2b3a67b727d4c4bf5959298e06c4e  9.1/RPMS/apache2-mod_ldap-2.0.45-4.3mdk.i586.rpm
b9b1060a89d663c312856939ff719e95  9.1/RPMS/apache2-mod_ssl-2.0.45-4.3mdk.i586.rpm
5c3186603f9c3f6ac37c90e5bf37f268  9.1/RPMS/apache2-modules-2.0.45-4.3mdk.i586.rpm
844ed273c5d02670336411c3886dc015  9.1/RPMS/apache2-source-2.0.45-4.3mdk.i586.rpm
138e432240b8cf43616b3dbcc028ab45  9.1/RPMS/libapr0-2.0.45-4.3mdk.i586.rpm
d31a62ca9bd9af08336b9a582246e22a  9.1/SRPMS/apache2-2.0.45-4.3mdk.src.rpm


Mandrake Linux 9.1/PPC:
3c04b040befea94653749da370d1fd24  ppc/9.1/RPMS/apache2-2.0.45-4.3mdk.ppc.rpm
7a2b57a3817fd9b9b12ba1ab18fc149c  ppc/9.1/RPMS/apache2-common-2.0.45-4.3mdk.ppc.rpm
628f0ddb0eeeb9c8ab1c438c4fcc11e5  ppc/9.1/RPMS/apache2-devel-2.0.45-4.3mdk.ppc.rpm
4dfd352417f72f57a6fdec6375ce2fc5  ppc/9.1/RPMS/apache2-manual-2.0.45-4.3mdk.ppc.rpm
c2c75171b467a740e5a460c9c204a8c3  ppc/9.1/RPMS/apache2-mod_dav-2.0.45-4.3mdk.ppc.rpm
9f5af5607b729d0d34761f3b55527901  ppc/9.1/RPMS/apache2-mod_ldap-2.0.45-4.3mdk.ppc.rpm
5dda8212a4a2f7a7f85f5cf38903f2ab  ppc/9.1/RPMS/apache2-mod_ssl-2.0.45-4.3mdk.ppc.rpm
7359a27567cab1add4dec16ca0599c72  ppc/9.1/RPMS/apache2-modules-2.0.45-4.3mdk.ppc.rpm
24abd44e8ecd2ca256d9918e3238f13d  ppc/9.1/RPMS/apache2-source-2.0.45-4.3mdk.ppc.rpm
1fb5c53305d7bdc52850b9adff612a7e  ppc/9.1/RPMS/libapr0-2.0.45-4.3mdk.ppc.rpm
d31a62ca9bd9af08336b9a582246e22a  ppc/9.1/SRPMS/apache2-2.0.45-4.3mdk.src.rpm

________________________________________________________________________

Bug IDs fixed (see https://qa.mandrakesoft.com for more information):
________________________________________________________________________

To upgrade automatically, use MandrakeUpdate.  The verification of md5
checksums and GPG signatures is performed automatically for you.

If you want to upgrade manually, download the updated package from one
of our FTP server mirrors and upgrade with "rpm -Fvh *.rpm".  A list of
FTP mirrors can be obtained from:

http://www.mandrakesecure.net/en/ftp.php

Please verify the update prior to upgrading to ensure the integrity of
the downloaded package.  You can do this with the command:

rpm --checksig <filename>

All packages are signed by MandrakeSoft for security.  You can obtain
the GPG public key of the Mandrake Linux Security Team from:

https://www.mandrakesecure.net/RPM-GPG-KEYS

Please be aware that sometimes it takes the mirrors a few hours to
update.

You can view other update advisories for Mandrake Linux at:

http://www.mandrakesecure.net/en/advisories/

MandrakeSoft has several security-related mailing list services that
anyone can subscribe to.  Information on these lists can be obtained by
visiting:

http://www.mandrakesecure.net/en/mlist.php

If you want to report vulnerabilities, please contact

security_linux-mandrake.com

Type Bits/KeyID     Date       User ID
pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team

<security linux-mandrake.com>

- -----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.0.7 (GNU/Linux)

mQGiBDlp594RBAC2tDozI3ZgQsE7XwxurJCJrX0L5vx7SDByR5GHDdWekGhdiday
L4nfUax+SeR9SCoCgTgPW1xB8vtQc8/sinJlMjp9197a2iKM0FOcPlkpa3HcOdt7
WKJqQhlMrHvRcsivzcgqjH44GBBJIT6sygUF8k0lU6YnMHj5MPc/NGWt8wCg9vKo
P0l5QVAFSsHtqcU9W8cc7wMEAJzQsAlnvPXDBfBLEH6u7ptWFdp0GvbSuG2wRaPl
hynHvRiE01ZvwbJZXsPsKm1z7uVoW+NknKLunWKB5axrNXDHxCYJBzY3jTeFjsqx
PFZkIEAQphLTkeXXelAjQ5u9tEshPswEtMvJvUgNiAfbzHfPYmq8D6x5xOw1IySg
2e/LBACxr2UJYCCB2BZ3p508mAB0RpuLGukq+7UWiOizy+kSskIBg2O7sQkVY/Cs
iyGEo4XvXqZFMY39RBdfm2GY+WB/5NFiTOYJRKjfprP6K1YbtsmctsX8dG+foKsD
LLFs7OuVfaydLQYp1iiN6D+LJDSMPM8/LCWzZsgr9EKJ8NXiyrQ6TGludXggTWFu
ZHJha2UgU2VjdXJpdHkgVGVhbSA8c2VjdXJpdHlAbGludXgtbWFuZHJha2UuY29t
PohWBBMRAgAWBQI5aefeBAsKBAMDFQMCAxYCAQIXgAAKCRCaqNDQIkWKmK6LAKCy
/NInDsaMSI+WHwrquwC5PZrcnQCeI+v3gUDsNfQfiKBvQSANu1hdulqIRgQQEQIA
BgUCOtNVGQAKCRBZ5w3um0pAJJWQAKDUoL5He+mKbfrMaTuyU5lmRyJ0fwCgoFAP
WdvQlu/kFjphF740XeOwtOqIRgQQEQIABgUCOu8A6QAKCRBynDnb9lq3CnpjAJ4w
Pk0SEE9U4r40IxWpwLU+wrWVugCdFfSPllPpZRCiaC7HwbFcfExRmPaIRgQQEQIA
BgUCPI+UAwAKCRDniYrgcHcf8xK5AKCm/Mq8qP8GE0o1hEX22QsJMZwH5gCfZ72H
8TacOb3oAmBdprf+K6gkdOiIRgQQEQIABgUCOtOieAAKCRCv2bZyU0yB80MeAJ9K
+jXt0cKuaUonRU+CRGetk6t9dgCfTRRL6/puOKdD6md70+K5EBBSvsG0OE1hbmRy
YWtlIExpbnV4IFNlY3VyaXR5IFRlYW0gPHNlY3VyaXR5QG1hbmRyYWtlc29mdC5j
b20+iFcEExECABcFAjyPnuUFCwcKAwQDFQMCAxYCAQIXgAAKCRCaqNDQIkWKmFi+
AJsHhohgnU3ik4+gy3EdFlB2i/MBoACg6lHn5cnVvTcmgNccWxeNxLLZI5e5AQ0E
OWnn7xAEAOQlTVY4TiNo5V/iP0J1xnqjqlqZsU7yEBKo/gZz6/+hx75RURe1ebiJ
9F779FQbpJ9Epz1KLSXvq974rnVb813zuGdmgFyk+ryA/rTR2RQ8h+EoNkwmATzR
xBXVJb57fFQjxOu4eNjZAtfII/YXb0uyXXrdr5dlJ/3eXrcO4p0XAAMFBACCxo6Z
269s+A4v8C6Ui12aarOQcCDlV8cVG9LkyatU3FNTlnasqwo6EkaP572448weJWwN
6SCXVl+xOYLiK0hL/6Jb/O9Agw75yUVdk+RMM2I4fNEi+y4hmfMh2siBv8yEkEvZ
jTcl3TpkTfzYky85tu433wmKaLFOv0WjBFSikohGBBgRAgAGBQI5aefvAAoJEJqo
0NAiRYqYid0AoJgeWzXrEdIClBOSW5Q6FzqJJyaqAKC0Y9YI3UFlE4zSIGjcFlLJ
EJGXlA==
=yGlX
- -----END PGP PUBLIC KEY BLOCK-----

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE+2+hVmqjQ0CJFipgRAuSwAJ9gIo7cwOQix9sCBsejpRQw/qoifQCguhDb
/7HSyaqH9G1mO8p3D/tEjz4=
=XaT0
-----END PGP SIGNATURE-----

If you have feedback, comments, or additional information about this vulnerability, please send us email.