Newtone Corporation Information for VU#210697

Newtone ImageKit ActiveX buffer overflow vulnerabilities

Status

Affected

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Vendor References

None

Addendum

Newtone ImageKit 5 users should upgrade to ImageKit 5 Fix 30 or later.

Newtone ImageKit 6 users should upgrade to ImageKit 6 Fix 41 or later.

Please note that although Newtone Corporation lists the fixes as "Repaired some minor issues in the ImageKit5 ActiveX" and "Repaired some minor issues with the ImageKit6 ActiveX", we have confirmed that the flaws in the control allow a remote attacker to execute arbitrary code on a vulnerable system.

If you have feedback, comments, or additional information about this vulnerability, please send us email.