search menu icon-carat-right cmu-wordmark

CERT Coordination Center

Wyse ThinOS LPD service buffer overflow vulnerability

Vulnerability Note VU#320233

Original Release Date: 2010-08-16 | Last Revised: 2010-08-16

Overview

Wyse ThinOS HF 4.4.079i has a buffer overflow vulnerability in the LPD service (515/tcp).

Description

The LPD service (515/tcp) on Wyse ThinOS HF 4.4.079i crashes when a long buffer is sent to it. This condition may exist in all versions before Wyse ThinOS 6.5.

Impact

An attacker can cause the device to crash and may be able to execute arbitrary code.

Solution

The vendor recommends users upgrade to Wyse ThinOS 6.5 or newer.

Restrict Access

Enable firewall rules to restrict access for port 515/tcp to only trusted sources.

Vendor Information

320233
 
Affected   Unknown   Unaffected

Wyse

Notified:  November 19, 2009 Updated:  August 16, 2010

Status

  Affected

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

The vendor recommends all users upgrade to Wyse ThinOS 6.5 or newer.

Vendor References


CVSS Metrics

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A

References

Acknowledgements

Thanks to Kevin Finisterres for reporting this vulnerability.

This document was written by Jared Allar.

Other Information

CVE IDs: None
Date Public: 2010-08-16
Date First Published: 2010-08-16
Date Last Updated: 2010-08-16 18:27 UTC
Document Revision: 23

Sponsored by the Department of Homeland Security Office of Cybersecurity and Communications.