search menu icon-carat-right cmu-wordmark

CERT Coordination Center


Filemaker Pro 5.0v3 and below does not adequately protect web-enabled databases

Vulnerability Note VU#33433

Original Release Date: 2000-12-15 | Last Revised: 2001-01-17

Overview

FileMaker may expose data inadvertently.

Description

FileMaker Web Companion prior to version 5.0v4 permits unauthorized access to data even if the database manager believes that data is protected by Field Level Security.

Impact

Attackers can read information, including items such as passwords, stored in databases thought to be protected.

Solution

Upgrade to 5.0v4 or later as described in http://www.filemaker.com/support/webcompanion_archive.html#may9.

Vendor Information

33433
Expand all

FileMaker

Notified:  May 01, 2000 Updated:  December 14, 2000

Status

  Vulnerable

Vendor Statement

Information from FileMaker can be found at http://www.filemaker.com/support/webcompanion_archive.html#may9

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Addendum

CERT/CC has not additional information at this time.

If you have feedback, comments, or additional information about this vulnerability, please send us email.


CVSS Metrics

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A

References

Credit

Our thanks to Erik C. Thauvin, of Blue World Communications, Inc., who reported this problem to us.

This document was written by Shawn V Hernan.

Other Information

CVE IDs: CVE-2000-0385
Severity Metric: 12.00
Date Public: 2000-05-01
Date First Published: 2000-12-15
Date Last Updated: 2001-01-17 05:16 UTC
Document Revision: 10

Sponsored by the Department of Homeland Security Office of Cybersecurity and Communications.