search menu icon-carat-right cmu-wordmark

CERT Coordination Center

OpenSSL contains integer overflow handling ASN.1 tags (2)

Vulnerability Note VU#380864

Original Release Date: 2003-09-30 | Last Revised: 2003-10-01

Overview

A vulnerability in the way OpenSSL handles ASN.1 tags could allow a remote attacker to cause a denial of service.

Description

OpenSSL implements the Secure Sockets Layer (SSL) and Transport Layer Security (TLS) protocols and includes a general purpose cryptographic library. SSL and TLS are commonly used to provide authentication, encryption, integrity, and non-repudiation services to network applications such as HTTP, IMAP, POP3, LDAP, and others. Clients and servers exchange authentication information in X.509 certificates. While the SSL and TLS protocols are not directly based on ASN.1, they do rely on ASN.1 objects used in X.509 certificates and other cryptographic elements (e.g. PKCS#1 encoded RSA values).

OpenSSL contains an integer overflow vulnerability in the way ASN.1 tags are handled. A specially crafted ASN.1 tag could cause the OpenSSL library to perform an out-of-bounds memory read operation. This could result in a denial of service, crashing the process using the OpenSSL library.

From the OpenSSL advisory:

2. Unusual ASN.1 tag values can cause an out of bounds read undercertain circumstances, resulting in a denial of service vulnerability.

All versions of SSLeay and versions of OpenSSL prior to 0.9.7c or 0.9.6k are vulnerable, as are operating systems and applications that use vulnerable SSLeay or OpenSSL libraries. The OpenSSL advisory describes as vulnerable "Any application that makes use of OpenSSL's ASN1 library to parse untrusted data. This includes all SSL or TLS applications, those using S/MIME (PKCS#7) or certificate generation routines."

The U.K. National Infrastructure Security Co-ordination Centre (NISCC) is tracking this vulnerability (VU#380864) and VU#255484 as NISCC/006489/openssl/1.

Impact

By providing specially crafted ASN.1 encoded data to a vulnerable system, a remote attacker could cause a denial of service. One potential attack vector is a client certificate message containing specially crafted X.509 certificates.

Solution

Upgrade or Patch
Upgrade to OpenSSL 0.9.7c or 0.9.6k. Alternatively, upgrade or apply a patch as specified by your vendor. Further information is available in an advisory from OpenSSL. Note that it is necessary to recompile any applications that are statically linked to OpenSSL libraries.

Vendor Information

380864
 
Affected   Unknown   Unaffected

OpenSSL

Updated:  September 30, 2003

Status

  Vulnerable

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Addendum

Please see <http://www.openssl.org/news/secadv_20030930.txt>.

If you have feedback, comments, or additional information about this vulnerability, please send us email.


CVSS Metrics

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A

References

Acknowledgements

This vulnerability was discovered and researched by NISCC

This document was written by Art Manion.

Other Information

CVE IDs: CVE-2003-0544
CERT Advisory: CA-2003-26
Severity Metric: 11.25
Date Public: 2003-09-30
Date First Published: 2003-09-30
Date Last Updated: 2003-10-01 22:26 UTC
Document Revision: 36

Sponsored by the Department of Homeland Security Office of Cybersecurity and Communications.