Vulnerability Note VU#581311

TP-Link EAP Controller lacks RMI authentication and is vulnerable to deserialization attacks

Original Release date: 26 Sep 2018 | Last revised: 16 Oct 2018

Overview

The TP-LINK EAP Controller is TP-LINK's software for remotely controlling wireless access point devices. EAP Controller for Linux lacks user authentication for RMI service commands, as well as utilizes an outdated vulnerable version of Apache commons-collections, which may allow an attacker to implement deserialization attacks and control the EAP Controller server.

Description

CWE-306: Missing Authentication for Critical Function - CVE-2018-5393

EAP Controller for Linux utilizes a Java remote method invocation (RMI) service for remote control. The RMI interface does not require any authentication before use. Remote attackers can implement deserialization attacks through the RMI protocol. Successful attacks may allow a remote attacker to remotely control the target server and execute Java functions or bytecode.

CWE-502: Deserialization of Untrusted Data - CVE-2015-6420

EAP Controller for Linux bundles a vulnerable version of Apache commons-collections v3.2.1 with the software, which appears to be the root cause of the vulnerability. Therefore, EAP Controller v2.5.3 and earlier are vulnerable to CVE-2015-6420 as documented in VU#576313.

EAP Controller v2.5.3 and earlier for Linux are affected by both vulnerabilities.

Impact

A Java application or library with the Apache Commons Collections library in its classpath may be coerced into executing arbitrary Java functions or bytecode.

Solution

There is currently no available update to EAP Controller to fully address the vulnerability. However, affected users may take the following actions to help mitigate and reduce risk. As described in VU#576313, updating the vulnerable libraries does not necessarily eliminate the vulnerability in all scenarios.

Update Apache commons-collections

Affected users should update the system Apache commons-collections library to at least version 3.2.2 or 4.1. For details, please see VU#576313.

Update the JRE version of EAP

Affected users should also update the Java Runtime Environment (JRE) used by EAP to the latest available version. Recent versions of JRE have improved deserialization protection features.

Vendor Information (Learn More)

VendorStatusDate NotifiedDate Updated
TP-LINKAffected03 Jul 201816 Oct 2018
If you are a vendor and your product is affected, let us know.

CVSS Metrics (Learn More)

Group Score Vector
Base 7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P
Temporal 5.9 E:POC/RL:OF/RC:C
Environmental 5.9 CDP:ND/TD:ND/CR:ND/IR:ND/AR:ND

References

Credit

Thanks to an anonymous reporter for reporting this vulnerability.

This document was written by Garret Wassermann.

Other Information

  • CVE IDs: CVE-2018-5393 CVE-2015-6420
  • Date Public: 18 Sep 2018
  • Date First Published: 26 Sep 2018
  • Date Last Updated: 16 Oct 2018
  • Document Revision: 85

Feedback

If you have feedback, comments, or additional information about this vulnerability, please send us email.