search menu icon-carat-right cmu-wordmark

CERT Coordination Center

HP Tru64 UNIX "ipcs" contains buffer overflow (SSRT0794U)

Vulnerability Note VU#771155

Original Release Date: 2002-09-09 | Last Revised: 2002-09-09

Overview

The HP Tru64 UNIX implementation of "ipcs" contains a locally exploitable buffer overflow.

Description

"ipcs" is used to report inter-process communication status. A locally exploitable buffer overflow in "ipcs" may permit a local attacker to gain elevated privileges and execute arbitrary code on a vulnerable host.

Impact

A local user may be able to gain elevated privileges and execute arbitrary code.

Solution

Apply a patch.

Vendor Information

771155
 
Affected   Unknown   Unaffected

Hewlett-Packard Company

Updated:  September 09, 2002

Status

  Vulnerable

Vendor Statement

http://wwss1pro.compaq.com/support/reference_library/viewdocument.asp?source=SRB0039W.xml&dt=11

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Addendum

The CERT/CC has no additional comments at this time.

If you have feedback, comments, or additional information about this vulnerability, please send us email.


CVSS Metrics

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A

References

Acknowledgements

This document was written by Ian A Finlay.

Other Information

CVE IDs: CVE-2002-0093
Severity Metric: 3.75
Date Public: 2002-07-19
Date First Published: 2002-09-09
Date Last Updated: 2002-09-09 13:53 UTC
Document Revision: 10

Sponsored by the Department of Homeland Security Office of Cybersecurity and Communications.