search menu icon-carat-right cmu-wordmark

CERT Coordination Center

Apple QuickTime Streaming Server vulnerable to DoS

Vulnerability Note VU#914870

Original Release Date: 2004-09-13 | Last Revised: 2004-09-15

Overview

There is a vulnerability in the Apple QuickTime Streaming Server that could allow a remote attacker to cause a denial-of-service condition.

Description

Apple's QuickTime Streaming Server provides an integrated distribution mechanism for various forms of digital content. There is a vulnerability in the QuickTime Streaming Server that could allow a remote attacker to cause a denial-of-service condition.

According to the Apple Security Advisory:
A vulnerability in the QuickTime Streaming Server can be exploited by malicious people to cause a DoS (Denial of Service) via a particular sequence of client operations. This vulnerability affects Server versions only.

The Apple Security Advisory does not specify the set of client operations used to trigger this vulnerability.

In order to regain functionality, the server must be restarted.

Impact

A remote attacker could prevent legitimate users from accessing the streamed content.

Solution

Apply Patch
Apple has released a patch to address this vulnerability in the Apple Security Update 2004-09-07.

Vendor Information

914870
 
Affected   Unknown   Unaffected

Apple Computer Inc.

Updated:  September 13, 2004

Status

  Vulnerable

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Addendum

Please refer to the Apple Security Advisory.

If you have feedback, comments, or additional information about this vulnerability, please send us email.


CVSS Metrics

Group Score Vector
Base N/A N/A
Temporal N/A N/A
Environmental N/A

References

Acknowledgements

This vulnerability was reported by Apple.

This document was written by Damon Morda based on information provided by Apple.

Other Information

CVE IDs: CVE-2004-0825
Severity Metric: 1.73
Date Public: 2004-09-08
Date First Published: 2004-09-13
Date Last Updated: 2004-09-15 17:29 UTC
Document Revision: 12

Sponsored by CISA.