OpenBSD Information for VU#637934

TCP does not adequately validate segments before updating timestamp value



Vendor Statement

A patch for OpenBSD 3.6 and previous releases is available at

OpenBSD 3.7, being released on May 19, is not vulnerable because
it contains the fix.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Vendor References



Please see and

[Note the CERT/CC has not verified the contents of the Vendor Statement above.]

If you have feedback, comments, or additional information about this vulnerability, please send us email.