Debian Information for VU#490620

Linux kernel do_mremap() call creates virtual memory area of 0 bytes in length



Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

The vendor has not provided us with any further information regarding this vulnerability.

Vendor References



Debian has published several advisories to address this vulnerability across multiple processor architectures. For further details, please see the document that corresponds to your processor architecture and kernel version:

    DSA-450-1 linux-kernel-2.4.19-mips -- several vulnerabilities
    DSA-442-1 linux-kernel-2.4.17-s390 -- several vulnerabilities
    DSA-440-1 linux-kernel-2.4.17-powerpc-apus -- several vulnerabilities
    DSA-439-1 linux-kernel-2.4.16-arm -- several vulnerabilities
    DSA-427-1 linux-kernel-2.4.17-mips+mipsel -- missing boundary check
    DSA-423-1 linux-kernel-2.4.17-ia64 -- several vulnerabilities
    DSA-417-1 linux-kernel-2.4.18-powerpc+alpha -- missing boundary check
    DSA-413-2 linux-kernel-2.4.18 -- missing boundary check

    If you have feedback, comments, or additional information about this vulnerability, please send us email.